Embedded Audio Recorder will not work on Chrome

hakangur's picture

Hello,

Using WordPress 5.2, I created an Audio Recorder activity (the content library is updated). Then, using the embed code, I embedded this activity into a Moodle (ver. 3.6.4) page - H5P is not installed in this Moodle website. Everything looks perfect, except that when I view the page in Chrome and click the "Record" button, I get this message: "Access to microphone is not allowed in your browser since this page is not served using HTTPS. Please contact the author, and ask him to make this available using HTTPS." Both the WordPress and Moodle websites use HTTPS. The problem persists when I clear the browser cache or when I log in with a different account.

When I try the same page and the activity with Microsoft Edge and Firefox (installed only a few minutes ago), there is no problem at all and the recording function works smoothly.

I know that this is a trivial issue but, as we say in Turkish, a fly is a small thing but it still makes you feel sick.

Summary: 
Embedded Audio Record gives HTTPS error in Chrome
BV52's picture

Hi hakangur,

Would you mind sharing the URL for your content so that we can check?

-BV52 

hakangur's picture

Originally, the link is to a university's LMS website and you cannot access it. Therefore, I created the same instance on my personal website. This time, the embedded H5P file is hosted here, at h5p.org.

Both are case sensitive. The login page is in Turkish but I believe you are familiar with the page layout. The link is https://dildersleri.gen.tr/mod/quiz/view.php?id=2386.

Edit: deleted password for security purposes

BV52's picture

Hi hakangur,

This issue happens because Chrome is blocking the access to the microphone when embedding using iframe. This can be resolved by editing the embed code and you can use the one below.

hakangur's picture

I tried the code above but the result was the same. Still, I thank you for the effort. We will simply add a notice to our exercise pages and ask users to use any browser except for Chrome. Since, as you mention, the issue has nothing to do with a core feature of H5P and this is a very rare case, I believe this can no longer be regarded as a bug.