Validating h5p package failed when trying to update Moodle plugin Interactive Video

I installed latest version of H5P Plugin two weeks ago on fully updated moodle server. Works flawlessly.
I am using Interactive Video (Really, really impressing - great tool!).

Since yesterday there is a warning "Update available" and a button to do a "Update now".
This button keeps spinning for a while but fails with the above message, which is detailed in Administration:

Das System kann die Komponente 'Interactive Video' nicht aus dem Paket installieren, weil dafür eine neuere Version des H5P-Plugins notwendig ist. Die Website arbeitet momentan mit der Version 1.12, notwendig ist die Version 1.13 oder höher. Sie sollten es nach einer Aktuallisierung noch einmal versuchen.

My list of installed libraries shows version 1.15 for this component.


Moodle Version: 3.2.2+ (2016120502.12)
Release: 05.03.2017
PHP: 7.0.15-0ubuntu0.16.04.4
MySQL: 10.1.23-MariaDB-1~xenial

fnoks's picture


The version number 1.13 is referring to the version of the core component of H5P, which is part of all the plugins (including Moodle). Try updating the H5P plugin, and you should be fine :)

Yesterday no update was seen by moodle, now there was one which solved everything.

tomaj's picture

Awesome that things are working! :)

- Tom