Two sites, same Moodle/H5P plugin version, one has higher library version and other can't be updated

I was wondering if someone could help me determine why two sites with the same Moodle version and same H5P plugin version have different versions for certain libraries.

Site A - Image Hotspots version 1.7.4

Site B - Image Hotspots version 1.8.1

I have updated content type cache on both. On Site A if I use the H5P hub to try updating Image Hotspots (create H5P activity>Select Image Hotspots>Details>Update) then we receive an error:

The system was unable to install the H5PEditor.ColorSelector component from the package, it requires a newer version of the H5P plugin. This site is currently running version 1.23, whereas the required version is 1.24 or higher. You should consider upgrading and then try again.Get help

According to the error we need to update the H5P plugin in order to get the new version of the colorselector component (and ultimately the new version of Image Hotspots), but this doesn't explain how Site B was able to acquire the newer version despite having the exact same plugin version.

BV52's picture

Hi phil.r,

Can you please double check if the H5P plugin version is 1.20.1 for the site that has this issue. If so can try downloading and uploading the sample content here. If it doesn't resolve the issue please check if you have any errors in the browser console.


Hi BV,

H5P plugin version is 1.19.1 for both sites. The issue isn't with specific content, the issue is that one site has a library version installed which is higher than the other site and it is impossible to update the library on the other site to bring it up to the same version.