The shortcode is not working with elementor page builder

Hi; 

I would like first to thank your for your great tool, you are providing an amazing service

I am using Elementor page builder in Wordpress. when I add the H5p's shordcode inside the Elementor it's doesn't work on cell phone but works fine on computer!!

Are there any conflict with H5P plunging and other pluging that embed the H5P shortcode?

Thank you in adanve for your support. 

Best regards. 

BV52's picture

Hi dido2038,

Do you have a sample content. I'm sorry I am unable to repro the issue since my test machine is not published.

-BV52

Hi BV52;

Please find attached a screen shot from the page and the sample content I have used.

Inside the green zone I used the short code [h5p id="3"], sometime it's works sometime not, especially when I checked the page on my cell phone.

For your information; the green zone is a text editor from Elementor page builder in wordpress.

 Best regards.

H5P file: 
Attachments: 

I'm having the same issue trying to use shortcode w/ Elementor.

When I add the short code using the "short code" widget...nothing happens.

Also, when I try to click the "add H5P" button...nothing happens.

Any guidance here?

Thanks!

Hi. I have the same issue. Nothing happens when I want to set up a shortcode or if I try to use the "add h5p"- button. Did anaybody solve this bug? 

otacke's picture

Hi!

Since this seems to be an issue with Elementor, have you asked them what the cause might be? https://wordpress.org/support/plugin/elementor/

Best,

Oliver 

I have been using WP with H5P, I embed my shortcode with the WP rich text editor and it has never cause any problem for me. 

Kim Gärtner's picture

Just wanted to say it is still a problem. Elementor says its a 3 party addon problem tell H5p.... H5p sends you to Elementor. I am able to use Shortcodes in Elementor but at this time only H5p is not working for me. It looks like there isnt any connection between the the two.

Hope the two will get together to solve the issue :-)

grats

otacke's picture

Hi Kim!

To me this feels a little like walking into a garage asking someone why your car would not start without even bringing the car or giving any other details.

I just installed Elementor on a WordPress platform. I can verify that the "Add H5P" button is not working in the text editor element. Didn't look for the reason as it works in regular WordPress. I tried to add H5P content using the shortcode element. Works. I tried to enter the shortcode in a text editor element. Works.

I don't doubt that you're having trouble, but at the top of https://h5p.org/forum/9 there's a list of infos that should be provided when reporting a bug. Otherwise it's often impossible to tell what might be wrong - back to the car analogy here. Please give more information or bring the car. Also, it's good to tell others what you have been trying to do to solve the issue (e.g. deactivating other plugins that might interfere in your case). This can rule out some things and you show that you don't simply want someone else to solve your problems for free.

Best,
Oliver

MariusP's picture

I can confirm that the H5P shortcode works in the text editor element. I didn't yet get it right with the shortcode element.