Nothing visible

Hello,

I've installed, with success I think the H5P plugin on my moodle website ( www.ent-lifdejakarta.ovh )

  • I can use it to create activities, I can save them but anything appears when I click on them. It's like the activitie code source were empty. Only the title of the activity is on the page.
  • I've checked the access autorisation for H5P content, everything is on for my profile. 
  • I've tried with many computers nor browser, the same.
  • I've checked that the plugin is activated.
  • I've tried with many kind of activities. The same: building and registering activitie is ok but seing it is impossible

My moodle site is 3.3 and the H5P plugin is 1.7. 

If anyone could help me, it would be great. This plugin seems amazing !

Best regards,

Lionel

 

Attachments: 
BV52's picture

Hi Lionel,

Can you please check the browser console (ctrl+shift+J) if you have any errors. Also would it be possible to provide a link that shows the issue.

-BV52

Thanks a lot for your feedback.

Here is what I get from the console (I've already try to uninstall/reinstall the plugin)

Uncaught SyntaxError: Invalid or unexpected token

h5p.js?ver=2018012200:861 Unable to find constructor for: H5P.MultiChoice 1.10

H5P.error @ h5p.js?ver=2018012200:861

h5p.js?ver=2018012200:981 Uncaught TypeError: Cannot read property 'getCopyrights' of undefined

    at Object.H5P.getCopyrights (h5p.js?ver=2018012200:981)

    at HTMLDivElement.<anonymous> (h5p.js?ver=2018012200:166)

    at Function.each (jquery.js?ver=2018012200:2)

    at init.each (jquery.js?ver=2018012200:2)

    at Object.H5P.init (h5p.js?ver=2018012200:92)

    at HTMLDocument.<anonymous> (h5p.js?ver=2018012200:2136)

    at c (jquery.js?ver=2018012200:2)

    at Object.fireWith [as resolveWith] (jquery.js?ver=2018012200:2)

    at Function.ready (jquery.js?ver=2018012200:2)

    at HTMLDocument.H (jquery.js?ver=2018012200:2)

Thanks a lot for your help.

Thanks a lot for your quick feedback.

Here is what I get from the console:

Uncaught SyntaxError: Invalid or unexpected token

h5p.js?ver=2018012200:861 Unable to find constructor for: H5P.MultiChoice 1.10

H5P.error @ h5p.js?ver=2018012200:861

h5p.js?ver=2018012200:981 Uncaught TypeError: Cannot read property 'getCopyrights' of undefined

    at Object.H5P.getCopyrights (h5p.js?ver=2018012200:981)

    at HTMLDivElement.<anonymous> (h5p.js?ver=2018012200:166)

    at Function.each (jquery.js?ver=2018012200:2)

    at init.each (jquery.js?ver=2018012200:2)

    at Object.H5P.init (h5p.js?ver=2018012200:92)

    at HTMLDocument.<anonymous> (h5p.js?ver=2018012200:2136)

    at c (jquery.js?ver=2018012200:2)

    at Object.fireWith [as resolveWith] (jquery.js?ver=2018012200:2)

    at Function.ready (jquery.js?ver=2018012200:2)

    at HTMLDocument.H (jquery.js?ver=2018012200:2)

 

 

Thanks a lot.

BV52's picture

Hi Lionel,

Thank you for the additional information. I filed a report and you can follow it here.

-BV52

I've updated moodle from 3.3 to 3.4.

Thanks to this update, H5P is now working.

Thanks a lot.

BV52's picture

Hi Lionel,

I'm glad to hear that it is working now and thank you for getting back to us on your resolution.

-BV52

Hi,
I have Moodle 3.1 and as admin I can see the H5P Content, but as a student I see a blank page.

Below is what the Console shows.
Any advice on how to resolve this? I'd deeply appreciate any idea

 

Default levels

Group similar

5 hidden

 

view.php?id=5191975:12 GET https://sameprod.moodle3.dev.openu.ac.il/pluginfile.php/2/mod_hvp/cachedassets/4cb780a….css 404 (Not Found)

view.php?id=5191975:111 GET https://sameprod.moodle3.dev.openu.ac.il/pluginfile.php/2/mod_hvp/cachedassets/4cb780a….js 404 (Not Found)

elegance.js:2 load elegance js

h5p.js?ver=2018012200:861 Unable to find constructor for: H5P.ImageMultipleHotspotQuestion 1.0

h5p.js?ver=2018012200:1773 Uncaught TypeError: Cannot read property 'on' of undefined at Object.H5P.on (h5p.js?ver=2018012200:1773) at HTMLDivElement.<anonymous> (h5p.js?ver=2018012200:205) at Function.each (jquery.js?ver=2018012200:2) at init.each (jquery.js?ver=2018012200:2) at Object.H5P.init (h5p.js?ver=2018012200:92) at HTMLDocument.<anonymous> (h5p.js?ver=2018012200:2136) at c (jquery.js?ver=2018012200:2) at Object.fireWith [as resolveWith] (jquery.js?ver=2018012200:2) at Function.ready (jquery.js?ver=2018012200:2) at HTMLDocument.H (jquery.js?ver=2018012200:2)

 

I forgot to mention that I've tested this in different browsers,
and got different results –
a student can see a certain activity on Firefox,
but the same student can't see that same activity on Internet Explorer

thomasmars's picture

Hi, it seems like you're not able to access the aggregated assets for some reason. If it works in one browser, but not another as the same role that is conspicuous. Can you check the requests for the file in firefox where it works, and compare it to the same request in IE ? and show the messages here.

Additionally do you have a public page where we can test this to see what is going wrong ?

Can you try to set $CFG->mod_hvp_aggregate_assets = 0; inside your config.php to see if this is what is causing your site to fail ?

- Thomas 

thanks for the quick response! I'll try...

This solved a problem we were having, THANK YOU

Moodle 3.6+

We were experiencing issues with the student role not being able to view video (interactive video/.mp4)...image/video wouldn't load.  Other roles (permission settings) could see the H5P asset. 

Changing the aggregate setting solved our issue.

Thank you for the information!