Interactive Video Error using Safari / IPAD after 1.14 Upgrade

Hi,

Here are my specs;

PHP: 5.6.38
MySql: 5.6.41
Apache:2.4.37

Moodle 3.2.2+
H5P: V1.14
Interactive Video: 1.20.3
Interactive Video Editor: 1.20.3
Interactive Video: 1.17.5
Interactive Video Editor: 1.17.4

My Problem:

I recently upgraded from H5P V1.7 to H5P V1.14 , after successfully getting it to run using Moodle 3.2.2+ (found a fix on the H5P.org site for this).

The problem I am having is with Interactive Video Content not running under Safari on the Ipad
(Note: Mozilla Firefox & Google Chrome are Fine)

1) Older Pre-existing Interactive videos created using Version 1.7 are working fine on all platforms after the upgrade (I'm assuming these were created using Interactive Video 1.17.5 library) and they have not been touched since the new 1.14 H5P has been installed

2) New Interactive Videos created using H5P V.14 are not rendering on the IPAD / Safari Browser.  The error I'm getting is "Video Format Not Supported". I'm assuming these videos are created using the 1.20.3 Interactive Video Libraries. As I said above, they work fine under Firefox and Chrome.

3) I did upgrade the Interactive Video Content Libraries once I upgraded to H5P V1.14 and I think this is were the problem lies. I've tested with the exact same mp4 video and have excluded any video format issues.

Is there anyway to downgrade the Interactive Video Library so I can testing if this is the issue. I'm hesitant to downgrade to V1.7 as I think this may create a lot of issues.

Best regards,

 

BV52's picture

Hi extensalogic,

Thank you for reporting this. There is an existing bug report and you can follow the progress here.

As for downgrading the libraries afaik there is no way of doing this not unless you uninstall the plugin and download the older version from github.  Also contents that were created with the newer version will not work as well.

-BV52