Dialog Cards Text editors - Paragraph format dropdown flickers

We have found an issue when using the H5P Interactive Content 'Dialog Cards' and clicking on the dropdown for 'Paragraph format' in any of the Text editors available, it continuously flickers. 

To replicate:

- Add an H5P Interactive Content activity to a Moodle Unit; 

- From the Editor, select 'Dialog Cards' from the Dropdown or search list; 

- Click in any of the 'Dialog Cards' text editor fields i.e. 'Title', 'Task description', 'Text', or 'Answer', and click the 'Paragraph format'

 

 

 

 

 

 

Content types: 
BV52's picture

Hi Monls,

I am unable to replicate the issue you metioned above.

In order to give your bug report the best chance of getting answered, please include the following information:

  1. Platform and version number. E.g. Drupal, Wordpress, Moodle.
  2. Mobile or Desktop
  3. Browser: Chrome, Firefox, Safari etc
  4. H5P plugin version
  5. H5P content type and version (if a content type was used), and a sample URL or attached H5P.
  6. Any browser console errors
  7. Any PHP errors
  8. Screenshots if it's a visual problem

The more information you provide, the quicker the community will be able to fix it and the quicker you'll have a working solution!

-BV52

We are using H5P within our LMS - Moodle 3.1
The issue occurs in all browsers
H5P plugin version - 2018012200
H5P content type - Dialog Cards
Our Moodle vendor has also investigated and advised that the issue is related to the H5P package, and not the Moodle side that contain the general H5P module configurations.  Also the issue only occurs with the Dialog Cards text editors and does not occur in any of the other 'Content Types'. 

BV52's picture

Hi Monls,

Can please provide the following.

  1. Any browser console errors
  2. Any PHP errors

-BV52

Hi BV52,

Please find the browser console logs below. They only appear the first time the dropdown is selected after the page is loaded. I've also tested on a local server running Moodle 3.5 using version 2018052400 of the H5P Plugin and the same issue occurs.

 

CONSOLE LOGS

Expected 'none', URL, or filter function but found 'alpha('.  Error in parsing value for 'filter'.  Declaration dropped.
editor_gecko.css:1:8796

Expected 'none', URL, or filter function but found 'alpha('.  Error in parsing value for 'filter'.  Declaration dropped.
editor_gecko.css:1:9219

Expected 'none', URL, or filter function but found 'alpha('.  Error in parsing value for 'filter'.  Declaration dropped.
editor_gecko.css:1:9400

Expected 'none', URL, or filter function but found 'alpha('.  Error in parsing value for 'filter'.  Declaration dropped.
editor_gecko.css:1:9751

Expected declaration but found '*'.  Skipped to next declaration.
contents.css:62:2

Unknown property 'tab-size'.  Declaration dropped.
contents.css:100:11

Kind Regards

Monls

otacke's picture

Hi Monls!

I can reproduce that behavior on a moodle instance, and I have created a bug report. You can track it in our ticket management system.

Best,
Oliver