"Start with bookmarks menu open" not showing

Hi BV52,

I just installed H5P for the 1st time yesterday and am having the same issue as eTeam.

The "Start with bookmarks menu open" option is checked on the backend but no menu is showing on the frontend. 

2 bookmarks are in my sample content below but no menu option to access these:

https://renerafael.com/antihero2-tests?n=xm10nasdjm&t=12&ACOS=45&torta=Ecos

Looking forward to hearing from ya :-)

Rene

 

It looks like the culprit ended up being when I also have this option enabled:

"Prevent skipping forward in a video"

Disabling this now shows the bookmark menu :-(

Is there a way to allow users to use the bookmark menu while preventing them from manually seeking by scrubbing the playhead?

The reason for this is because I really need them to use a chapter menu system (provided by bookmarks) that ONLY allows them to seek to these predetermined spots but no others.

Thanks again :-)

Rene

BV52's picture

Hi Rene,

Now that you mentioned it you are correct, if you enabled "prevent skipping forward" this also prevents the bookmarks from working. This is more of a feature request than a bug since there needs to be an exception created in the code for bookmarks to work.

I have moved this post to the feature request forum.

-BV52

Thanks for that BV52 - truly excited by that possibility and in H5P in general :-)

Hi BV52,

Just checking-in to see if there's a patch or mod I can appy to achieve this feature to help you avoid affecting the rest of your user population? :-)

Thank you sir!

R

BV52's picture

Hi R,

There is no patch or mod available but you can make the changes yourself or if you have access to a developer. These documentation can get you started.

-BV52