Version 1.1.0 of the reporting module is required to render this report. Currently installed: 1.0.0

After the upgrade released on Friday, when I check the report of the activity via gradebook, I get the message

"Version 1.1.0 of the reporting module is required to render this report. Currently installed: 1.0.0" for some students, but not al of them. I have no reference of what reporting module this is so I can upgrade.

Is anyone having the same isue? Or knows how to fix this?

Best

Attachments: 
BV52's picture

Hi paulteach,

Which content are you having problems with? Is this from all contents or just specific ones?

-BV52

It was apparently fill in the blanks only. We solved the problem by changing the version of the reporting module to 1.1.0 in the module folder. The weird thing is that the report didn't show for some students but did for others in the same course (moodle) and activity.

Thanks for your reply anyway.

BV52's picture

Hi paulteach,

I'm glad you got it working and thank you for getting back to us with your resolution.

-BV52

21cccs's picture

Hi -- How can I apply this fix on a hosted environment where code changing is not an option? I have students who can't see their results and it's getting frustrating for them. I don't see "Reporting" as one of the libraries to update in Moodle 3.7

Hello Paul,

The same message appears to me. Can you please let me know how you updated the reporting module to 1.1.0? I work at a university in Turkey and the Moodle administrators don't know much English so they have trouble finding how to do this update.

I appreciate your help.

Nuria

Sorry I took so long to reply.

Login to your server with an ftp client and go to "...yourmoodleinstallation/mod/hvp/reporting" and edit line 9 of the file 'h5p-report.class.php' from "private static $version = '1.0.0';" to "private static $version = '1.1.0';"

That did it for me!

"...yourmoodleinstallation/mod/hvp/reporting" and edit line 9 of the file 'h5p-report.class.php' from "private static $version = '1.0.0';" to "private static $version = '1.1.0';"

It works for me too.  Thanks so much paulteach

Sorry I took so long to reply.

Login to your server with an ftp client and go to "...yourmoodleinstallation/mod/hvp/reporting" and edit line 9 of the file 'h5p-report.class.php' from "private static $version = '1.0.0';" to "private static $version = '1.1.0';"

Thank you paulteach!

This resolved the issue for me too.

Hello,

I see you solution is from 2019 but this week (oct 2020) the reporting problem suddenly occurs. I did change what you been writing about but the problem seems to stay.

Is there any update that solves this problem? I'm using Moodle 3.8 (only the last update from last week I did not do, I'm waiting for the november holiday)

Is this a problem that occurs only with fill in blanc when I use more than one answer???

Is this problem solved when I would only use one answer in the fill in blanc type H5P?

In my case the problem occurs when using fill in blanc in a interactive video

Can you help me out here????

Thanks

Hello there,

I've got a problem with re-using h5p from elder versions or saving corrections in h5ps which have been created with elder versions.

Any Course Presentation, Interactive Video, Column, Dialogue Cards cannot be saved with a correction.

Does anyone know a good workaround?

Tx

Da Johannes

BV52's picture

Hi Da Johannes,

If you are using one of the three frameworks (Drupal, Moodle or Wordpress) updating the library cache should resolve this issue.

-BV52

Hi

We're running the latest version of Moodle and H5P, and I have updated the library cache but still receive this message.

Thank you in advance for any assistance.  

BV52's picture

Hi lerouxh,

Do you see any errors in the browser console?

-BV52

Thank you for your response. No errors on the web console. 

Besides the message in reporting, the 'fill in the blanks' questions stopped working all togehter on our staging envorment. I re-installed H5P, but no luck.

BV52's picture

Hi lerouxh,

Please post a screenshot of the list of H5P libraries. Also please double check the browser console for any errors, this usually gives us clues to what is causing the issue.

-BV52

Hi,

I also have this error on a fresh moodle installation (around 1 week ago). I have no error in the console log. It's "fill in the blank" in a "course presentation" which seems to raise this error message.

Here a screenshot of my plugin list

Sorry I took so long to reply.

Login to your server with an ftp client and go to "...yourmoodleinstallation/mod/hvp/reporting" and edit line 9 of the file 'h5p-report.class.php' from "private static $version = '1.0.0';" to "private static $version = '1.1.0';"

Hi,

I also have this error with a fresh (arround 1 week ego) moodle installation from scratch.

Thanks

 

otacke's picture

It's an unfortunate event with a content type that has been released requiring a feature in the reporting module that still has the update pending for review.

Okay thanks. Meanwhile I did the "manual fix" suggested before.

(i just hope the manual fix will not prevent the update when it will be released)

otacke's picture

No. Your changes will be overwritten.

Hi, how am I going to learn that this update is available? Will it install itself (on moodle)?

otacke's picture

It's part of the moodle plugin. So when it's done and there's an update for the moodle plugin, you'll get it with that one.

Hi,

Just checking to see if there any updates to this issue? 

Thanks,
Phil.

+1 on this update. I see there is a comment in the GitHub regarding this bug: https://github.com/h5p/moodle-mod_hvp/issues/302

Version 1.1.0 of the reporting module is required to render this report. Currently installed: 1.0.0"

 

I have this problem just today..... I'm using moodle 3.8

I tried to change 1.0.0 to 1.1.0 on line 9 as suggested but without result.  What can i do please since updating to moodle 3.9 is not a option at this moment. 

Thanks