loading, please wait

I can no longer customize the existing content and create no new content
loading, please wait

The existing content works correctly

I have leardash with wordpress installed

BV52's picture

Hi klaasdeboer,

In order to give your bug report the best chance of getting answered, please include the following information:

  1. Detailed steps to reproduce the bug (exactly how and when did it happen)
  2. Platform and version number. E.g. Drupal, Wordpress, Moodle.
  3. Mobile or Desktop
  4. Browser: Chrome, Firefox, Safari etc
  5. H5P plugin version
  6. H5P content type and version (if a content type was used), and a sample URL or attached H5P.
  7. Any browser console errors
  8. Any PHP errors
  9. Screenshots if it's a visual problem

The more information you provide, the quicker the community will be able to fix it and the quicker you'll have a working solution!

-BV52

When I choose "add new" and then use the H5P content hub to get the course presentation the editor does not load, I just get a spinning wheel with "loading, please wait" (see screenshots). It doesn't matter if I try to make it from scratch or upload an existing presentation. The error occurs on https://module13.ca and not on any of my other WordPress multisites.

  • Wordpress v. 5.2.1
  • Desktop
  • Firefox 67
  • H5P 1.13.1
  • when I click H5P libraries in WP I have 2 course presentations listed: 1.16.0 and 1.20.4
  • For all H5P content types I get a statement like this in the browser console "The script from “https://module13.ca/courses/files/h5p/libraries/H5PEditor.CoursePresenta...” was loaded even though its MIME type (“text/plain”) is not a valid JavaScript MIME type."
  • The only difference I can really see between this WPMS and others I have is that this one also uses the H5P mods plug-in https://github.com/jrdingwall/h5pmods-wordpress-plugin (the plug in worked fine a few months ago, I just noticed the error I'm having in the plast few weeks)
  • see screenshots

Thanks for any help you can provide!