Interactive video format not supported

Hi

I'm using an interactive video - which clearly states that it surpports Vimeo - however when I copy over the URL - I get an unknown format.  Anyone else know how to fix this?

 

Content types: 

hi - vimeo is not supported ,  Anyone know why?

BV52's picture

Hi janne.butcher,

This page should explain why this is not working and how to make it work ;-)

-BV

Hi BV

thanks for the thread - the page looked promising.  I was able to bring over the High Def Link, and then it accepted the source, however I still get a big black Video Format not supported.  any ideas?

Hello BV, same issue here.

I have a Vimeo Pro account and I followed all the steps here.

I got my direct link to the mp4 file, as in this picture:

2021-02-16-105226-1280x1024-scrot

This is the link: https://player.vimeo.com/external/512847260.hd.mp4?s=c297fd32f71620170419728367f39d5c333f1bc2&profile_id=174

My H5P plugin on Moodle could recognize immediately the mp4 format (see picture)

2021-02-16-105621-869x521-scrot

But when I start to add interaction to my video I get a "Video format not supported" error, like this.

2021-02-16-105901-789x506-scrot

I also tried to use set privacy on Vimeo allowing everybody to access and to embed the video (usually I use private links and I limit embedding possibilities to the domains of my University). Nothing changed.

2021-02-16-110035-1280x1024-scrot

Any suggestion?

Thank you very much!

 

daniele

 

PS: I interacted with this old post because I can not access the forum or the comments on the page on Documentation. I can log in to my profile, but the website logs me out every time I change page...

otacke's picture

Hi!

It seems that vimeo is not giving out the direct link anymore, but only a preliminary one. If you open it in your browser, it will forward you to https://vod-progressive.akamaized.net/exp=1613497821~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2569%2F20%2F512847260%2F2371696481.mp4~hmac=c41f5e87c7c7ed226ec047584261f30fdbb97d2e43ed845736dcccabcf308360/vimeo-prod-skyfire-std-us/01/2569/20/512847260/2371696481.mp4?filename=TEST.mp4 which is the direct link that you can use. I am not entirely sure though that this is a "stable" link that will be valid indefinitely.

Best,

Oliver 

Thank you very much for your answer.

Vimeo is still producing these links:

1280x720: https://player.vimeo.com/external/512847260.hd.mp4?s=c297fd32f7162017041...
960x540: https://player.vimeo.com/external/512847260.sd.mp4?s=6e78f53281e91859481...
640x360: https://player.vimeo.com/external/512847260.sd.mp4?s=6e78f53281e91859481...

However, when you paste them into your browser, they change the way you noticed. I suppose this is normal and unrelated to the issue.

Also using these "second step" links in my interactive video I cannot solve the problem.

Any idea?

Many thanks!

 

d.

otacke's picture

Hi! 

I don't have any trouble using the resolved links, see https://h5p.org/node/1108996 for https://vod-progressive.akamaized.net/exp=1613497821~acl=%2Fvimeo-prod-skyfire-std-us%2F01%2F2569%2F20%2F512847260%2F2371696481.mp4

Best,

Oliver 

BV52's picture

Hi daniele,

I can confirm what Oliver mentioned, I can also use all 3 links that you provided without any issues.

-BV

Hello, thank you very much for your answers. It seems that the bug (probably a missing plugin or some too restrictive permissions) is inside our Moodle installation.

I tried again and I succeeded using the file on https://h5p.org/ sandbox, while everything remain the same on my Moodle. Please have a look to the demonstration:

I will involve our IT department to better understand what is happening. Now I'll challenge the BIG issue... H5P and MS Stream... (answer: not possible).

Thank you very much to all!

daniele