Missing required library H5PEditor.ColorSelector 1.3

Hi,

I am trying to do a wordpress upload for a Branching Scenario H5P file that I created and downloaded from my account in H5P.com (on trial) While I am doing it, I am getting the following error : Missing required library H5PEditor.ColorSelector 1.3
What I have tried so far:I followed the solution posted by BV here and also by others by uploading other sample files but it is not working. I created a similar file on H5P.org but still getting same error in wordpress. Could you please help me with this? All other files are uploading fine and the plugins, wordpress and Php are all up to date.

Thanks
Vir

 

   

Hi guys, the issue is resolved. It was a plugin setting error.

BV52's picture

Hi Vir,

I'm glad you got it working and thank you for informing us. I'm curious though which specific setting was it?

-BV

Hello,  I made a branching scenario quiz. I am having the corresponding .h5p downloaded from h5p.org. Now when I am uploading it, I am getting the same error: 

: Missing required library H5PEditor.ColorSelector 1.3

Kindly guide me as to how this could be resolved. 

     

stubot's picture

I had the exact same issue, after much Googling and experimenting here is my solution:

Force the ColorSelector library (1.2.6) to update by importing a new content type that isn't already installed. I used Image Hotspots and downloaded the example from:

https://h5p.org/image-hotspots

This added the new version H5PEditor.ColorSelector (1.3.0)

N.B. I was unable to update this ColorSelector library via the 'H5P Hub' interface, an update option was never presented to me.

stubot's picture

I had the exact same issue, after much Googling and experimenting here is my solution:

Force the ColorSelector library (1.2.6) to update by importing a new content type that isn't already installed. I used Image Hotspots and downloaded the example from:

https://h5p.org/image-hotspots

This added the new version H5PEditor.ColorSelector (1.3.0)

N.B. I was unable to update this ColorSelector library via the 'H5P Hub' interface, an update option was never presented to me.

BV52's picture

Hi stubot,

Thank you for the suggestion. Another user suggested something similar by installing Interactive Video.

-BV

I just got hit by this error. I am using the H5P WordPress plugin, in the current version of 1.15.3. When trying to install the Branching Scenario, the package H5PEditor.ColorSelector1.2 is reported missing. I managed to get v1.3 pulled in by installing Image Hotspots. But apparently that does not satisfy the dependency, as it the error reporting v1.2 missing persists.

Any chance getting this fixed upstream?

HI, Did you find a solution,I have the exact same problem

1791 Delegates's picture

Dear H5P Colleagues,

We are also getting the same error code when trying to update the H5P Interactive Video:

"Validating h5p package failed. Missing required library H5PEditor.ColorSelector 1.3"

https://jmp.sh/3b7wCzY

We're using H5P Version: 1.15.4

Thanks for your help!

 

I'm getting this exact error today as well.

I have this same error too using the Drupal module.

BV52's picture

Hi Everyone,

Can you please try downloading the sample content and then upload it to see if it will update IV.

Edit: I was informed that we just released an update to fix this issue can you please confirm that this can be updated?

-BV

The update worked!

BV52's picture

Hi esomething,

Thank you for confirming the resolution.

-BV