Installation of h5p on Moodle MAMP (Mac)

Hi.

I'm new to h5p. I'm testing it out offline on a mac using 'MAMP' (Moodle installation). I can't seem to install h5p. I download the package (as a zip file) from the moodle website. Then within Moodle, I go to Administration > Install Addons. I locate the file, and press upload, but it doesn't install. I get to a screen which says 'Moodle 3.5 - Install plugin from ZIP file - Validating mod_hvp...' but the installation does not get any further than this. I have managed to install a different package on Moodle, so it looks as if there is nothing wrong with my MAMP installation.

Any pointers welcome!

Hi. I re-downloaded the h5p package, and now I can install. Obviously something happened with the initial download. Hooray!

BV52's picture

Hi Nick,

I'm glad that it is working now, if you have further questions feel free to post in the forums.

-BV52

Same problem here: stalls while validating. I have MAMP 3.4 installed and the H5P zip is "mod_hvp_moodle35_2018053100.zip". Is there a 3.4 specific plugin package that I need? 

I'm having the same issue, stalling during validation. I have MAMP 3.4 installed and the downloaded plugin zip is "mod_hvp_moodle35_2018053100.zip". Is there a 3.4 plug in version that I need? 

BV52's picture

Hi Chris,

Since you are you using an old version of MAMP can you please check if the PHP version is 5.2 or higher. If so please provide the following:

  1. Detailed steps to reproduce the bug (exactly how and when did it happen)
  2. Platform and version number. E.g. Drupal, Wordpress, Moodle.
  3. Mobile or Desktop
  4. Browser: Chrome, Firefox, Safari etc
  5. H5P plugin version
  6. H5P content type and version (if a content type was used), and a sample URL or attached H5P.
  7. Any browser console errors
  8. Any PHP errors
  9. Screenshots if it's a visual problem

The more information you provide, the quicker the community will be able to fix it and the quicker you'll have a working solution!

-BV52

 

Also - MAMP 4.1.1 shows PHP 7.0.15

Hi - thanks for the reply. Sorry for the double post originally.

  1. The issue is that I'm using MAMP 3.4, trying to install the H5P plug-in and at the end of the H5P module install it hangs on: Validating mod_hvp ... 
  2. Moodle 3.4
  3. Desktop (Mac OSX 11.13.6) - MAMP is installed on the system drive (an SSD) formatted with Apple's new file system: APFS
  4. Chrome 67.0.3396.99
  5. Release 1.9
  6. Just trying install the module in MAMP - no content yet
  7. No browser errors
  8. No PHP errors
  9. No visual issues

Any help is greatly appreciated.

Chris

 

thomasmars's picture

Hi,
Make sure you have followed https://h5p.org/installation/configure-phphttps://h5p.org/moodle and https://docs.moodle.org/35/en/Installing_plugins.

Also make sure that the web server is able to write to the required folders, as described in https://docs.moodle.org/35/en/Installing_Moodle.

Best regards, Thomas

Thanks for the info. Re-downloading the h5p package worked for me.

I've had the same problem for several hours, I changed max_execution_time in php.ini to 60 seconds (from 30), and now its worked fine.

Hi there

Do you still use moodle4mac? (or MAMP) I had the same issues as you.

Atleast I got it on moodle, but know I have problems oploading content.

Do you have the same issue? 

Best 

Malte 

Hi there

I know it's an old thread, but I am actually trying to combine H5P with moodle through MAMP with a moodle4mac package. 

Hence I wanted to ask what your experiences are? I use moodle 38. and I had the same problems which are mentioned above. 

I could solve it, but sometimes it works, sometimes it doesn't. My mainproblem though is that I cant realy upload any h5p file.

I just get the error 500 message. What could be the cause? 

Best 

Malte 

 

gregafb's picture

Same problem than other with the Moodle4Mac-38 pack 

BV52's picture

Hi Malte and gregafb,

I used to run on a similar setup. If it is a fresh install of MAMP, Moodle and H5P you need to increase both the file upload size and maximum execution time.

-BV

mark-zajac's picture

You wrote: "you need to increase both the file upload size and maximum execution time."

What are good values?

[:-)] Mark

BV52's picture

Hi Mark,

For the file upload size I usually set it up to around 100MB since I've sometimes needs to test files with that size. For the max execution time I usually have it at around 300. Please note that I have a local setup (offline) so this might not always be applicable for everyone.

-BV

gregafb's picture

Same problem , with the Moodle4Mac-38 pack when installing mod_hvp_moodle38_2020020500  :-(

Guys,

I have 2 separate hosted Moodle installations and a local (Moodle4Mac) and have never managed to export/import H5P files from one installation to another. I have spent a lot of time ensuring the instances are an exact match in terms of versioning.

It is a shame and basically means we have no choice other than to work in our 'live' environment.

 

 

Allright, did you try to export/import the whole course, or just the h5p file? I oploaded a h5p file from moodle4mac into wordpress and it worked fine.  

BV52's picture

Hi jp,

Are you getting any error messages?

-BV

@bv52 If I get a chance sometime I will retry and make a note of the errors.

Thanks for the reply BV.

Yes I get the Error 500. I did all the things you mentioned, but maybe I did something wrong. 

I went into the config map and the to the php.ini file and I changed the numbers with a normal text editor, and saved. 

Best 

Malte

BV52's picture

Hi Malte,

I think it's best to continue this on your other post since it has a lot more details.

-BV